Thunderbird 31 on Linux

I had not upgraded thunderbird in a long time. But recently Google deprecated their V1 Calendar API so the version of Calendar Provider for Google 0.25 no longer worked.

NOTE FOR 0.31 AND 0.25 USERS
After a previous announcement, Google has shut down the v1 API today (November 17th) that version 0.32 and 0.25 has been using. This means those versions will no longer work and you MUST upgrade to 1.0.x to continue using the Provider for Google Calendar.

So I took the plunge and upgraded from Thunderbird 17 to Thunderbird 31.3. After rebooting it detected that Lightning was out of date and automatically updated it. But when Thunderbird finally started up I got pop-up errors like this:

An error was encountered preparing the calendar located at https://auto

Turns out this was an issue with the version of Exchange Provider I was using. So I uninstalled Exchange Provider and Provider for Google Calendar and installed the latest. Provider for Google Calendar was version 1.0.2.
The Exchange Provider was no longer available but the latest version is known as Exchange EWS Provider 3.3.0 and is available here. The new version works much slicker. Auto-detect had no issue getting my Exchange Calendar.
I ran into one more issue trying to set up my Google Calendar. The wizard was not working the way it was documented. I found out the issue was again Exchange. So I disabled Exchange EWS Provider, restarted, added my Google Calendar, enabled Exchange EWS, restarted and all my Calendars were back.

Advertisements

Tags: , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: